Patch 3.3 Pet hotbar function broke for me with patch, does anyone know what I’m doing wrong?

Patch 3.3 Pet hotbar function broke for me with patch, does anyone know what I’m doing wrong?

Whoops:

I meant to put this in User Interface but I’m too tired and got my browser tabs mixed up, if a CM could move this to User Interface — Thank You. If not, well at least this problem is relevant in many Dungeons (Meridianum, Praetorium, Stone Vigil HM, etc etc).

Before Patch 3.3:

Normal pet hotbar (playing SCH or SMN): Pet Hotbar was hidden, because I have all abilities keybound on normal hotbars or macros.
Get on a Pet (Chocobo Porter, Cannons in Meridianum, Magitek Armor in Praetorium, etc): My ‘Hotbar 1’ turned into ‘Pet Hotbar’ and I can activate Pet abilities (like Photon Cannon or Dismount) using Hotbar 1 hotkeys.
Get off Pet (Dismount Porter, leave Cannon, etc): My ‘Hotbar 1’ with normal Class/Job abilities returned again.

After Patch 3.3:

Get on a Pet: Nothing changes, my ‘Hotbar 1’ stays there but all abilities gray out. I cannot use any Pet Actions.
Get off Pet: My ‘Hotbar 1’ disappears and gets replaced by SCH pet (Selene) abilities. No way to get ‘Hotbar 1’ back without manually changing Hotbar page all the way back to 1 (using arrows).
Normal pet hotbar: I still want it to be hidden, but now I have to show it all the time or I can’t use abilities on Special Pets (Porters, Cannons, etc). I have to click abilities on Special Pets because they don’t respond to ‘Hotbar 1’ binds anymore.

I didn’t change any of my Character Configuration → Hotbar settings after Patch 3.3, so I don’t know what I’m doing wrong that suddenly broke this.

If anyone knows, it would help so much, this is making all mechanics that use Special Pets like Armor, etc much more awkward.

Leave a reply

Your email address will not be published. Required fields are marked *